有任何上古卷轴的问题,请直接到MOD社区发帖求助

常见 OBSE 插件介绍

借助OBSE 插件,我们可以减少游戏对系统的占用,从而大大的提高工作效率,比如大家非常熟悉的内核汉化插件obcn.dll。这边具体介绍《上古卷轴4:湮没》常见的一些OBSE插件。

引言

你需要先按前一篇文章安装OBSE。
所有OBSE插件安装的方法都是把文件安装到Oblivion/Data/OBSE/Plugins内。
为了方便 Wrye Bash 安装,我们的建议是如下方式打包

Data\
….obse\
……..plugins\
…………OBSE插件
说明文档

下面介绍几个常见的obse插件:

内核汉化 obcn_12416.dll

※此插件属必装插件
实现游戏内中文字符的显示,当前普遍使用的版本为0.0.16.0,通常来自于上古卷轴4内核汉化v1.2
为了与DarkUI等模组兼容,安装完此插件后记得运行 obcn_config.exe 修改字体。

关于游戏内中文的输入(感谢 lina19870606 ):
以玩家取名为例,在输入栏中单击鼠标,出现光标后按下F10,这时候会换到画面左上角,可切换输入法,输入完中文按回车即可。

【存在的问题】
1、与特定版本的MenuQue冲突,详见下面对MenuQue的介绍;
2、虽然已经是使用dll来实现中文字符的显示,但你仍能察觉出游戏加载速度变慢,尤其是大量mod的游戏中特别明显;
3、Steam 玩家需要额外的解决方案

内核日化 obja.dll

详见 日本語化パッチ – Oblivion 日本語化 Wiki 避難所
注:此网站可能需要翻墙查看,否则会出现Error界面。
安装后可显示日文,注意:不可与内核汉化同用

【存在的问题】
1、同内核汉化存在的问题;
2、与obse v0019冲突,需要使用最新版(v0.16 beta3,下载的压缩包好像有问题)。

Fast Exit v2

※此插件属必装插件
主要作用:实现游戏快速退出并且不出错。
T网载点:注意是下载v2版,否则会CTD。

Elys’ Universal Silent Voice (USV)

※此插件属必装插件
下载链接:T网载点 | Elys’ Universal Silent Voice (USV)
游戏中不可能每个对话都有相对应的声音,特别是业余玩家制作的mod,通常这种情况下将出现对话一闪而过。此mod的作用是给每个多少声音文档的对话添加8s长度的静止声音,从而让对话出现停留8s。
如果游戏设置中关闭了字幕,此插件将强制开启缺少语音文件的对话的字幕。
如果不喜欢这个mod的还可以选择40SilentMp3s
部分mod要求更长的声音长度,你可以尝试 Ely_s_Universal_Silent_Voice_-_Longer_Patch.7z,是14s的声音长度。

Pluggy

※此插件属必装插件
OBSE括展,新增许多OBSE缺少的功能。可实现创建/管理数组、字符串、ini文档、文本文档以及HUD,同时可修改对象名。
下载链接:T网载点 | Pluggy介绍
T网上版本很多,该选哪个版本?根据mod作者的要求选择。最新版本是132,虽然是beta版,但很多人一直在使用,并且长时间没发现严重性bug,所以可以放心使用。
使用详细说明

Oblivion Shutter Remover (OSR)

※此插件属推荐插件
主要是优化游戏,减少卡顿。
下载链接:T网载点 | OSR介绍
T网上版本很多,该选哪个版本?
4.1是正式版,4.1.24是RC版,4.1.26是未完成版。通常是使用4.1.24,有部分人是使用 4.1.24+4.1.26(使用 4.1.26 里面的sr_Oblivion_Stutter_Remover.dll,剩余的文件都来自于4.1.24)
另外,可能有人会从 New Vegas 或者 Fallout 那么找到更新的版本,其实关于Oblivion的部分没有差别。
使用详细说明

【存在的问题】
Ini的配置因电脑的配置存在很大的差别,无法简单的复制别人的ini从而达到对方所说的效果,你必须自己不断测试找出最适合自己电脑的ini设置。

ConScribe

※此插件属推荐插件
可能很多人没听过,不过还是需要把它编入推荐插件,用过的人都说好。
一般用户使用是为了将控制台的内容保存到txt文档中。主要是为了查错使用。
简单点说,许多mod加载前需要先初始化,并且初始化完成后将在控制台输入相应类似于Initialised(初始化完成)、Loaded(已加载)的信息,游戏内部控制台显示的行数有限(可以通过PgUp/PgDn上翻/下翻),查看比较不方便。通过查看控制台我们可以很快的发现哪些mod正常加载了,哪些mod又加载出错了。
主要是方便mod制作者测试mod所用,但大家都知道Oblivion特容易出错,所以普通用户也推荐安装。
下载链接:T网载点 | ConScribe 100-26510-10-0.zip
同其他obse插件相同,直接安装,内含ini配置文档(运行完游戏后生成),默认设置已经够了,所以这边不对ini进行更深一步的介绍。
安装完后,运行游戏,将产生文件夹 Oblivion\Data\ConScribe Logs,其中 Static Log.log 里面即控制台出现过的所有内容。

Oblivion -Elys- Uncapper

提到属性、技能、等级中100上限到200
下载链接:T网载点 | Oblivion-Elys-Uncapper_v0.96-13841.7z

【存在的问题】
建议改用下面的AV Uncapper

AV Uncapper

移除Actor Value的上限。针对不同的Actor Value,“移除……上限”有不同的含义,不过大体的思路就是允许浮点数据的出现。举例说,对 Resistances 或 Armor Rating 而言,浮点数据的出现意味着可替换原游戏的规则。对属性与技能而言,则表示移除100的上限,同时修改游戏规则进而让100+的数值有实际意义。
整个插件的工作主要是依靠一系列GMSE(Game Settings)来协调,默认的数值等同于原版游戏,如果想实现其他效果,必须通过esp修改GMST。其中,内置的 AVUncapper_Example.esp用来移除所有支持的 Actor Value 的上限(效果类似于 Oblivion -Elys- Uncapper )。AV Uncapper Settings则允许用户通过ini进一步自定义。
下载链接:T网载点 | AV_Uncapper_v1_beta1-34841.7z
此插件功能与 Oblivion Ely’s Uncapper 功能类似,并且更广,所以可以替换掉对方,但记住千万不要同时使用 AV Uncapper 与 Oblivion Ely’s Uncapper 。

【存在的问题】
标注为beta版,但实际已经很稳定了,只是还有一些 Actor Value 也是可以移除上限的,而作者还没完成该部分内容。

AddActorValues

允许用户自定义新的Actor Value。使用此插件的人一般是因为他在使用 Sneaking Detection Recalibrated
下载链接:T网载点 | AddActorValues-33248.7z

【存在的问题】
旧版本会与 RBP 冲突,请更新到最新版。

NifSE

Unnecessary Violence 以及 Deadly Reflex 需求此插件,导致此插件的流行。
括展 Oblivion 脚本以实现 Niflib 的功能,即可以在游戏过程中通过脚本读取/修改 nif 动作文件。
最新版是v1.1,主要是解决v1.0里面BSA读取中出错的bug。
下载链接:T网载点 | NifSE_v1_1_Release-21292-1-1.7z

【存在的问题】
国内很多人仍旧在使用v1.0,关于v1.0的bug,其实很容易就可以发现bug:一开始从地牢出来后,往帝都市场区的那条路走,在加载地图的时候你就会CTD。强烈建议更新到v1.1。

MenuQue

主要是UI(用户界面)括展,部分mod需要用到。
下载链接:T网载点
MenuQue_v7-32200.zip
MenuQue_v16b-32200.zip

【存在的问题】
已经确认MenuQue较后面的版本会与内核汉化冲突。
所以,T网这么多版本,我应该下载哪个版本?如果你使用内核汉化的话,请选择v7版;如果你未使用内核汉化的话,请使用最新版(v12)
虽然上面说到v7才与内核汉化兼容,但平时测试中,有发现v6仍然与内核汉化不兼容
如果想要安装最新版又想要内核汉化的话,可以关掉 MenuQue 的 Extra Font 功能,具体的是打开 obse\Plugins\OBSE_Kyoma_MenuQue.ini ,并修改 bAllowExtraFonts=1 为  bAllowExtraFonts=0 ,但这样设置仍不能游戏的稳定性,有些mod需要高版本的 MenuQue 是为了 Extra Font (如 HUD Status Bars 和 Enhanced Hotkeys),你禁掉的话将导致读档跳出(不禁的话是打开游戏跳出)。

weOCPS

帮忙跳过一些常见的CTD,减少游戏出错的次数。
下载链接:T网载点 | weOCPS_2009.03.28-22282.zip

【存在的问题】
依旧只是测试版,无法保证稳定性,不过这点问题不大,主要问题是后面的……
因为避过CTD,会导致一些错误数据保存到存档中,长期如此会导致存档坏死。
针对存在的问题,到底要不要使用这个插件?我们的建议:如果你觉得存档坏死无所谓的话,你可以无视此插件的bug。不过,特殊情况下,你可以借助这个插件来查错,因为每当它避过一个CTD的话,系统都会发出类似于“滴”的声音,表示在这边原来的游戏是会CTD的,这种情况下,你应该尽可能的找出出错的原因。

RefStuff

没什么好讲的,只有一种情况你会需要它:你安装了 Fearsome Magicka
下载链接:T网载点 | Refstuff_plugin-30973-1.rar

【存在的问题】
使用 OBSE 启动 CS 的时候不要安装此插件,否则 CS 会出错

ALGOHOL

让游戏支持Vector3 结构
一般都不会使用到,仅在安装 Fearsome Magicka 时需要用到
下载链接:T网载点 | ALGOHOL_v011-13337.zip

VipCxj’s Plugin Collection

Vipcxj的部分mod需要用到
下载链接:T网载点 | VipCxjs_Plugin_Collection-v3-37075-3-0.7z

Sound Commands

部分mod需要,早前的夜光版不小心整合过
下载链接:T网载点

【存在的问题】
会导致CTD,所以不建议安装;安装夜光版的用户如果发现OBSE\OBSE Plugins下有SoundCommands.dll的都请删掉

Enhanced Music and Control

部分mod需要,早前的夜光版不小心整合过
下载链接:T网载点

【存在的问题】
会导致CTD,所以不建议安装;安装夜光版的用户如果发现OBSE\OBSE Plugins下有EnhancedMusicControl.dll的都请删掉

补充:关于 Enhanced Music and Control 的跳出,有人提到了一个解决办法,下载 Mp3tag 或者类似的程序,然后把游戏里面的声音文件的MP3 Tag(标签)都删掉。这样子以后CTD应该能够解决。

icedream

About icedream

其实我知道的东西很少,只是翻译了一些东西,悲催的是翻译过后很快就忘了。

, ,

One Response to 常见 OBSE 插件介绍

  1. 姬神乱舞 2013 年 3 月 5 日 at 下午 10:37 #

    今天找属性过100现在该装哪个,意外看到冰大你的这篇帖子,看完之后顿时觉得大彻大悟,立地成佛,哦米拖佛,以前我玩巫师塔重建的MOD一直装Sound Commands和Enhanced Music and Control,估计我就是栽在这上面