有任何上古卷轴的问题,请直接到MOD社区发帖求助

Wrye Bash 教程第一堂——介绍与安装

本来是不可能这么早写这篇文章的,现在我完全不知道以后的 Wrye Bash 要怎么发展。总之,如果现在你在阅读此文章,那么请记住一点:本教程适用于v296-v304。早期的版本或者后期的版本不一定适用。

Anyway, 这几天开始开始写 Wrye Bash 的教程,大概进程是 2~3 天出 1 篇。

这次介绍 Wrye Bash 的功能与安装。

介绍 · Description

就当前而言,Wrye Bash 应该算是《上古卷轴4:湮没》与《上古卷轴5:天际》中最强大的工具,你既可以把它用来安装mod,还可以用来排序mod;既可以用来检查安装包的冲突,还可以用来减少mod的冲突。另外,你还可以对存档进行管理、调整、优化,同时,还支持INI编辑功能。

大略来说,功能有:

  • mod安装与冲突管理;
  • 插件排序管理;
  • 减少mod间的冲突;
  • 通过整合插件,实现超过 255 个插件同时使用;
  • ini调整与管理;
  • 截图管理;
  • 更多的功能,等着你去慢慢发现。。。

缺点是功能太多,对于初学者来说,看起来很复杂。

如果你想较好的掌握 Wrye Bash,我建议认真阅读接下来将要介绍的内容,一天消化一点,遇到不懂的积极求助。你总会懂得的。

安装 · Installation

Wrye Bash 比较复杂的便是软件本身的安装。。。这边介绍几种安装方式

使用UOTP安装(Oblivion 向)

下载最新版的 Unofficial Oblivion Tools Package 并安装,安装的时候在 选择组件 时选择 独立版(普通用户) 或者 Python版(高级用户),并且在 软件需求 页面把不满足前提条件的程序给补上;
UOP 安装 Wrye Bash - 选项选择

使用USTP安装(Skyrim 向)

下载最新版的 Unofficial Skyrim Tools Package 并安装,安装的时候在 软件需求 页面把不满足前提条件的程序给补上;

使用官方安装程序安装

到官网(SourceForge|T网|S网)下载 Wrye Bash xxx – Installer.exe 并安装,安装的时候在 Installation Location(s) 时选择 Standalone 或者 Python ,并且在 Installation Prerequisites 页面不满足前提条件的程序给补上;
Installer 安装 Wrye Bash - 选项选择

使用官方压缩包安装

依旧是到官网(SourceForge|T网|S网)下载,不过这边需要下载的是 Wrye Bash xxx – xxx.7z 。也就是 Wrye Bash xxx – Python Source.7z 或者 Wrye Bash xxx – Standalone Executable.7z

普通用户推荐使用 Wrye Bash xxx – Standalone Executable.7z 。

一般不推荐 Wrye Bash xxx – Python Source.7z ,除非你是使用 SVN 或者你本身对 Python 有所了解(如果不知道什么是 SVN 或者 Python 的请直接选 Wrye Bash xxx – Standalone Executable.7z )

Standalone Executable的安装

1、安装 MSVC++ 2008 redistributable (32位 | 64位
2、使用7zip(winrar或者其他压缩程序也可以,但是这边推荐7zip)打开 Wrye Bash xxx – Standalone Executable.7z ,会发现只有一个文件夹 Mopy 。
3、解压压缩包并复制内容到 游戏目录 (OblivionLauncher.exe 或者 SkyrimLauncher.exe 所在位置),覆盖原有文件。

Python Source的安装

1、按顺序安装以下程序(必须选择win32的,不要安装win64,即使你是64位系统)

2、与 Standalone Executable的安装 同样的方法,把 Wrye Bash xxx – Python Source.7z 的内容解压到游戏目录内。

注意事项

Standalone Executable 与 Python Source 不要安装在一起,也就是说:

  • 过去我安装的是 Standalone Executable ,那么这次我就继续使用 Standalone Executable 。
  • 过去我安装的是 Python Source ,那么这次我就继续使用 Python Source 。

两次安装的版本不要冲突!

Wrye Bash 300 – Python Source 的注意啦!!
如果你发现你的 Wrye Bash 运行不正常了,比如
Traceback (most recent call last):
File "bash\bash.pyo", line 362, in main
File "bash\bosh.pyo", line 31182, in initBosh
File "bash\bosh.pyo", line 30923, in initDirs
File "bash\bosh.pyo", line 30841, in getPersonalPath
File "bash\bosh.pyo", line 30729, in getShellPath
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 10: ordinal not in range(128)

那么,请重新安装上面提到的 python-2.7.3 等程序!

下一篇教程链接:Wrye Bash 教程第二堂——运行程序

icedream

About icedream

其实我知道的东西很少,只是翻译了一些东西,悲催的是翻译过后很快就忘了。

,

25 Responses to Wrye Bash 教程第一堂——介绍与安装

  1. KUBI 2013 年 8 月 20 日 at 上午 1:18 #

    问一下,前天手贱把老滚删了,今天重新下了解压版的最老版本,具体版本号忘了,1.1几的吧也许。然后把备份的DATA拷过去,直接TESV进游戏小窗口能进,然后TESV LAUNCHER以后进游戏MOD全部没了,于是在这里下了这个http://tesfans.org/unofficial-skyrim-tools-package/,装了以后把MOD都勾上了进去首先告诉我要最新的SKYRIM,然后把SK什么的那个勾去掉以后能用WB进游戏,但是问题来了,进游戏读档还是开新档全部都自动跳出……原本为了解决自动跳出我调了缓存所以只要不折腾就不会跳但是这个开新档也跳……这是怎么回事,MOD太多了?不科学啊……

    • icedream 2013 年 8 月 20 日 at 上午 10:49 #

      现在都哪个版本了,你知道吗?

      • KUBI 2013 年 8 月 20 日 at 上午 11:07 #

        嗯我知道啊,但是因为之前打的东西有点多而且有点乱,后来一不小心直接打了11号补丁没打10号游戏进不了了于是才又下了老版本还原的,所以说是版本不支持的问题么?

        • icedream 2013 年 8 月 20 日 at 下午 11:50 #

          您觉得呢,这种情况下我觉得应该安装最新版,然后完全抛弃早期的所有内容。

  2. 2013 年 9 月 8 日 at 上午 10:57 #

    运行 Wrye Bash后显示是英文的,我用的是Wrye Bash 304 – Installer-22368-304,能改为中文的吗

  3. 2013 年 12 月 6 日 at 上午 2:45 #

    我的Wrye Bash 运行出现Traceback (most recent call last):
    且重新安装上面提到的 python-2.7.3 等程序都无法解决!
    大神求解!

  4. Xin桑 2013 年 12 月 15 日 at 上午 7:15 #

    IceDream大人,我能把你的汉化地址发布在另一个论坛吗?

    • icedream 2013 年 12 月 15 日 at 下午 12:42 #

      当然